Funktionen

Funktionen

Dokumenten-Verwaltung

PVG.view kann mehrere Dokumente gleichzeitig öffnen. Dieses Verhalten kann in den Einstellungen unter Allgemein ein- und ausgeschaltet werden. PVG.view merkt sich die zuletzt geöffneten Dateien. Diese Liste ist im Menü Datei verfügbar. Zwischen den geöffneten Dokumenten können Sie mit den Funktionen im Menü Fenster umschalten. Dort lassen sich auch Fenster anordnen oder schließen.

Möglichkeiten ein Dokument zu öffnen:

  • Menü Datei → Öffnen...
  • Menü Datei → Zuletzt geöffnete Dateien
  • Mit Drag-and-Drop kann eine Datei in das PVG.view Fenster gezogen werden. Nach dem Loslassen der Maustaste wird die Datei geöffnet.
  • Übergabe als Programmparameter. Der Aufruf von pvgview dateiname startet PVG.view und öffnet das Dokument dateiname.

Folgende PVG.view Startoptionen stehen Ihne zur Verfügung:

  • -lLändercode: -len pvgview -len startet PVG.view in englischer Sprache (-lde in deutsch).
  • -c"Menutext": PVG.view führt nach Laden der angegeben Datei den Befehl aus. Man kann mehre Befehle auf einmal angeben - mit ";" getrennt. z.B.: -c"Anpassen Breite";"Einstellungen" passt die Ansicht an die Breite des Dokumentes an und ruft anschließend Bearbeiten → Einstellungen auf.
  • -h: Gibt die Startoptionen an.

Ansicht

Vergrößern / Verkleinern

PVG.view erlaubt eine stufenlose Verkleinerung oder Vergrößerung im Bereich 0,0001 x bis 10.000 x.

Um einen bestimmten Bereich der Seite zu vergrößern, wählen Sie das Werkzeug Rechteck vergrößern. Mit diesem Werkzeug können Sie einen rechteckigen Ausschnitt vergrößern. Ziehen Sie dazu einfach ein Rechteck um den gewünschten Bereich. Das Werkzeug Rechteck verkleinern arbeitet ähnlich. Je kleiner das Rechteck desto stärker wird die Ansicht verkleinert.

Feste Vergrößerungsstufen können sie mit diesen Werkzeugen setzen:

  • Verkleinern / Vergrößern im Menü Ansicht, in der Werkzeugleiste, dem Kontextmenu oder der Statusleiste
  • Über die Auswahlliste in der Statusleiste

Über die Auswahlliste in der Statusleiste können Sie einen beliebigen Vergrößerungsfaktor als Prozentzahl eingeben.

Mit der Funktion Anpassen Original (Taste O) wird die Ansicht wieder auf 100% gesetzt. Wenn das Dokument von der Größe nicht vollständig angezeigt werden kann, können Sie die Ansicht mit dem Scrollbalken oder dem Verschieben Werkzeug aus dem Menü Ansicht verändern.

Seite einpassen

Der Vergrößerungsfaktor kann so gesetzt werden, dass die Seite genau in das Dokumenten-Fenster passt. Sie können die Seitenbreite (Anpassen Breite), die gesamte Seite (Anpassen Fenster) oder den Seiteninhalt (An Inhalt Anpassen) als Grundlage für den neuen Vergrößerungsfaktor nehmen. Anpassen Original setzt die Vergrößerung auf 100%.

Drehen

Das Dokument lässt sich in 90°-Schritten drehen. Verwenden Sie dazu die entsprechenden Funktionen aus dem Menü Ansicht.

Übersicht

Die Übersicht zeigt eine Miniaturansicht der aktuellen Seite. Ein Rechteck markiert den aktuell sichtbaren Bereich. Wenn Sie das Rechteck in der Übersicht verschieben, wird die Ansicht entsprechend verändert. Sie können die Übersicht über den Punkt Übersicht im Menü Ansicht aktivieren. In den Einstellungen (Bearbeiten → Einstellungen) können Sie die Größe des Fensters bestimmen.

Lupe

Wenn Sie das Lupen-Werkzeug aktiviert haben, erscheint bei gedrückter Maustaste eine vergrößerte Detailansicht an der aktuellen Mausposition. In den Einstellungen (Bearbeiten → Einstellungen) können Sie die Größe des Fensters und die Vergrößerungsstufe bestimmen.

Einzel- und Mehrseitenanzeige

Bei PDF- und Tiffdateien steht Ihnen dieser Befehl zur Verfügung. Bei Mehrseitenanzeige werden die einzelnen Seiten des Dokumentes untereinander platziert und dargestellt.

Navigation

Bei mehrseitigen Dokumenten können Sie vor und zurückblättern, zur ersten oder letzten Seite springen oder direkt eine bestimmte Seitenzahl aufrufen. Die Funktionen finden Sie im Hauptmenü, in der Werkzeugleiste, im Kontextmenü und in der Statusleiste.

Farbinformation

Ist die Funktion "Farbinformation" aktiv, so wird bei jedem Maus-Klick der nächster Endpunkt der Elemente im Dokument gesucht und der Farbwert ermittelt. Dieser Farbwert wird anschließßend im Ausgabefenster als RGB-Wert geschrieben.

Selektives Anzeigen der Elemente

Diese Funktionen zeigen in Rot alle Texte, Linien, Fächen und Bilder an. Jeweils die verbleibenden Elemente werden grau dargestellt.

Messen

Mit der Messen Funktion können Sie Entfernungen und Flächen bestimmen. Dazu platzieren Sie eine Reihe von Messpunkten im Dokument. Die Messpunkte können entweder frei platziert werden oder an den Linien-Endpunkten eingerastet werden (Fangen). Die Messergebnisse werden im Ausgabefenster protokolliert und können mit Hilfe der Zwischenablage weiterverwendet werden. Es kann zwischen einer Linien und Polygonmessung umgeschaltet werden.

Messwerkzeuge

Das Messen Werkzeug lässt sich über das Menü oder die Werkzeugleiste aktivieren. Wenn das Messwerkzeug aktiv ist, wird eine zusätzliche Werkzeugleiste eingeblendet. Diese enthält eine Reihe von Informationen über die Messung und einige Schalter. Die Koordinaten X und Y geben die relative Position zum letzten Messpunkt an. Auch der Abstand bezieht sich auf den letzen Punkt. Der Winkel wird anhand der letzten Teilstrecke berechnet. Solange der Meßpfad nicht abgeschlossen wurde, werden Umfang und Flächeninhalt unter der Annahme eines geschlossenen Messpfades berechnet.

Messpunkte

Um einen Punkt zu setzen, klicken Sie mit der Maus auf das Dokument. Jeder weitere Mausklick fügt einen Punkt zum Messpfad hinzu. Sie können die Messung jederzeit mit der ESC Taste beenden. Um die Messung abzuschließen, wählen Sie den Knopf Ende in der Messen Werkzeugleiste. Mit dem Schließen Knopf können Sie den letzten Messpunkt mit dem Ersten verbinden. Den zuletzt gesetzten Messpunkt entfernen Sie mit dem Knopf Punkt löschen (Rücktaste).

Das Festlegen der Messpunkte kann auf zwei Arten beeinflusst werden. Die erste Möglichkeit ist der Orthogonal Modus. In diesem Modus werden die Messpunkte in 45° Winkeln zum letzten Messpunkt ausgerichtet. Der Modus kann über den Knopf Orthogonal dauerhaft ein- und ausgeschaltet werden. Vorübergehend lässt sich der Orthogonal Modus mit der Umschalt Taste wechseln. Die Zweite Möglichkeit ist der Fangen Modus. Mit ihm werden die Messpunkte an den Vektor-Linien-Endpunkten ausgerichtet. Der Fangen Modus kann ebenfalls in der Messen Werkzeugleiste oder mit der Strg Taste umgeschaltet werden.

Maßeinheit kalibrieren

Es gibt die Möglichkeit, die angezeigte Einheit für das Koordinatensystem zu transformieren. Das geschieht mit Hife des Messwerkzeugs. Damit ist es z.B. möglich, Entfernungen in Zoll statt Meter anzuzeigen.

Um die Einheit zu kalibrieren, legen Sie einen Meßpfad fest (s. Messen), dessen Länge Sie kennen. Um die Kalibrierung zu aktivieren betätigen Sie den Schalter Kalibrieren in der Messen Werkzeugleiste. Im erscheinenden Dialog können Sie die neue Länge der gewählten Strecke eingeben. Die Bezeichnung der Einheit kann frei gewählt werden. Wenn wieder die ursprüngliche Einheit des Dokumentes angezeigt werden soll können Sie die Kalibrierung über das Messwerkzeug wieder deaktivieren.